Back to overview
Downtime

Landing page is unavailable

Mar 6, 2026 at 3:03pm UTC
Affected services
culta.ai, culta.ai/login

Resolved
Mar 6, 2026 at 3:46pm UTC

We have identified and resolved the issue. Services should now work as expected.

Updated
Mar 6, 2026 at 3:40pm UTC

We have pushed a potential fix. We will continue monitoring.

Created
Mar 6, 2026 at 3:03pm UTC

Landing page is currently unavailable in some regions. We are investigating a fix.